User Tools

Site Tools


database:oracle:ubuntu_php7_apache2

Install Ora8 on Ubuntu 16.04 to use with Apache2 and PHP7

Don't mind the version numbers

apt-get install php-pear php-dev build-essential unzip libaio1

Download oracle instant client basic and SDK and unzip them

mkdir /opt/oracle
unzip instantclient-basic-linux.x64-12.2.0.1.0.zip /opt/oracle
unzip instantclient-sdk-linux.x64-12.2.0.1.0.zip /opt/oracle/instantclient_12_2
chown -R root:www-data /opt/oracle
cd /opt/oracle
mv instantclient_12_2 instantclient
cd instantclient
echo /opt/oracle/instantclient > /etc/ld.so.conf.d/oracle-instantclient
echo /opt/oracle/instantclient >> /etc/ld.so.conf
ldconfig
ln -s libclntsh.so.11.2 libclntsh.so
ln -s libocci.so.11.2 libocci.so
 
pecl install oci8
echo extension=oci8.so >> /etc/php/7.0/apache2/php.ini
echo extension=oci8.so >> /etc/php/7.0/cli/php.ini
service apache2 restart

When prompted to enter instant client home, use instantclient,/opt/oracle/instantclient

database/oracle/ubuntu_php7_apache2.txt · Last modified: 2017/08/10 10:59 (external edit)